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FilmBars Graphics User Manual
Introduction 
The FilmBars Graphics package has been designed to enable you to originate highly accurate barcode symbols for integration into your desktop processing package. A wide range of symbologies and additional features are included to help you design your barcode, including a large choice of file extensions to permit compatibility with most artwork generation programs. 

This user guide has been designed to provide you with information and operational instructions for the FilmBars Graphics software package. It provides instructions on installation and use of the software, and guides you through the process of generating your own barcodes. 

This manual has been written to incorporate both the Windows and Macintosh versions of FilmBars Graphics and is relevant to versions 3.2.04 (Windows) and 3.1.51 (Macintosh) upwards. 
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Chapter 1 - Installation 
Installing the Software 
The FilmBars software has been provided on a CD-ROM for installation purposes, if you do not have a CD-ROM drive then please contact Axicon who can provide you with an alternative media. 

System Requirements 
Windows 
· PC 386/486 or higher 

· Windows 95/98/2000/NT operating system 

· At least 8Mb of RAM 

• At least 4Mb of free hard disk space 

Macintosh 
· Macintosh Performa 68xxx and later 

· System 7.0 or later 

· At least 4Mb of RAM (preferably 8Mb) 

· At least 4Mb of free hard disk space 

Installation 
Windows 95/98/2000/NT 
Before you can run your Windows FilmBars software as a full version, you will need to install your dongle (without the dongle the software will run in demonstration mode and will only operate a total of five times). Installation of the dongle is performed by attaching the male end of the dongle into the PARALELL PRINTER port at the back of your PC (note, the dongle must not be plugged into a 25 pin serial port). Your printer cable can then be plugged into the back of the dongle to perform as usual. 

Insert the CD into your CD-ROM drive on your PC, the CD should Autorun and provide you with on screen instructions to follow.  Should the CD fail to automatically run you can manually start it by selecting ‘Run’ from the ‘Start’ menu and using the ‘Browse’ option locate and double click on the ‘Setup.exe’ file in your CD-ROM drive. 

NOTE: Following installation of the FilmBars software you will be asked if you would like to install the HASP driver, you must go through with this installation process in order for your dongle to operate properly. 
Macintosh Insert the CD-ROM into your CD-ROM drive and double-click on the CD icon, then double-click on the FilmBars Graphics Installer icon and follow the onscreen instructions. 

Chapter 2 - Software Basics

Upon completion of the installation a FilmBars directory will have been created in your computer (in the ‘Start’ menu in Windows and in the Macintosh hard drive).  In this directory there are two options: FilmBars Editor and the FilmBars program. We will go into the uses of the Editor later in the manual, for now you will need to open the FilmBars program. 

The instructions below have made references to the pull down menus located near the top of the FilmBar Window,  but you can often access the same features using the toolbar buttons located below the pull down menus. 

2.1 Creating your First Code 
Across the top of the FilmBars window there are a variety of menu options to allow you to create and manipulate your barcode symbols. To create your first code you will need to begin by selecting your code type. 

Barcode types 
At the top left hand corner of the software window there is pull down menu displaying the barcode symbologies available to you (only the symbologies that you chose to be included when you purchased the software will be displayed). Select the symbology you would like to use from the menu. 

Creating a new code. 
From the ‘File’ pull down menu select ‘New’.  The ‘Symbol Properties’ window will now appear which allows you to enter your barcode number and select which options you require. The other options displayed in this window allow you to manipulate the size and structure of your barcode which you can just leave as the default if you do not wish to alter any of these features (for instructions on using these options see Chapter 3 - In-Depth Features). Pressing the OK button will now create your barcode on screen. 

2.2 Basic Editing 
Bearer Bars/Frames/Corner Marks: You can add a variety of lines and marks around your barcode such as bearer bars (used particularly in the ITF and EAN128 symbologies) and frames or corner marks (which can be used to protect the light margins of your code).  These choices are found under the ‘Bearer Bars’ option of the ‘Options’ menu. 

Rotating: You can rotate your barcode 0, 90, 180 or 270 degrees (Windows version only) by using the ‘Rotation’ alternative from the ‘Options’ menu. 

Text: You can add a text accompaniment to your barcode using the ‘Text’ option from the ‘Options’ menu.  There are a total of four text lines available and each can be positioned above or below the barcode and in a variety of justifications. 

Quality Control Marks: You can add a variety of Quality Control marks to your barcode for the purposes of monitoring your print quality. 

2.3 Saving, Exporting and Re-Opening your Barcode 
Saving and Exporting 
Once you have created your barcode and performed any necessary editing you are ready to save/export your barcode to a format that you can utilise. If you would like to retrieve your file for future use then you will need to save it as a FBS (FilmBars Symbol) file, this can be done from the ‘File’ pull down menu by selecting the ‘Save As’ option.  Once you have saved your file as a FBS, you can then select the ‘Export’ option from the pull down menu (Windows only, Mac version uses ‘Save As’ only).  From the ‘Export’ window you can select your saved FBS file and export it to the file type of your choice from the pull down menu on the right hand side. Pressing ‘Export’ will now export your barcode in the specified format to the directory shown ready for use in your artwork (the default location of this directory can be altered using the ‘Preferences’ option of the ‘Options’ menu, (Windows only)). 

If you do not need to retrieve this file for future use under the FilmBars package, then this process can be simplified. Select the ‘Save As’ option from the ‘File’ pull down menu and instead of saving as a FBS you can choose from the options in the ‘Save As Type’ box to save directly under your required file type. 

Opening an Existing File 
To open a file that you have already created and saved as a FBS file you need to select the ‘Open’ command from the ‘File’ menu.  You can then access the properties of this file by selecting the ‘Properties’ option from the ‘Edit’ menu, or by double-clicking on the image. 

More detailed information on the above options and further features can be found in the next chapter - ‘Chapter 3 - In-Depth Features’. 
Chapter 3 - In-Depth Features 
3.1 Barcode Generation Options 
Symbol Properties Options. The ‘Symbol Properties’ window can be displayed one of three ways, either by selecting the ‘File’ ‘New’ option, by double clicking on an active barcode or by selecting ‘Properties’ from the ‘Edit’ menu.  The options available in the ‘Symbol Properties’ window are dependant on the symbology in use and will contain a combination of the following: 
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‘Code’: This mandatory field allows you to enter the characters that you wish to use in your barcode. Certain symbologies are restricted in their structure and length, and non-adherence to the rules of each symbology type will result in the error ‘Error:Code’. 

‘Split’: The split button will be available for many symbologies and allows you to enter data for a barcode as separate fields to simplify the process of concatenation for some of the more complex symbologies. For example, when generating a ITF-14 barcode you can press the ‘Split’ button which will bring up the ‘Split’ window.  In this window you then have the opportunity to break down the data entry into the Logistic Variable, EAN-13 and Supplement boxes. Closing the window with the ‘OK’ button will then automatically calculate the correct format for your ITF-14 code, eliminating the EAN-13 check digit and calculating the new ITF-14 check digit. 

‘Grouping’: The grouping button allows you to select from the range of options how you would like your human readables displayed underneath your barcode. 

‘Analyze’: This button is used mainly under the EAN-128 symbology option to simplify your data entry for different Application Identifiers (AI’s).  Pressing the ‘Optimize’ button at the base of the ‘Analyze’ window will concatenate your AI’s to the most suitable configuration. 

‘Ext. Keys’: Activating this button will bring up the ‘Extended Keys Table’ window, from here you can insert one of a range of normally non keyable characters (such as ASCII 1-31 and Start, Function, Shift etc) by double clicking on the required character.  You will automatically exit the Extended Keys Table window upon selection of a character, alternatively you can use the Escape key to close the window without selecting a character. 

An alternative way to introduce the special symbol characters is to use the following keyboard shortcuts. 

Ctrl c+1 [Fnc1] c+2 [Fnc2] c+3 [Fnc3] c+4 [Fnc4] c+5 [StartA] c+6 [StartB] c+7 [StartC] c+8 [CodeA] c+9 [CodeB] c+0 [CodeC] c+s [Shift] (Not Mac) 

Table 1. Keyboard shortcuts 
‘Check Char’: This tick box refers to the check character (check digit), and gives you the option to add a check digit to some symbologies where a check digit is not mandatory. Ticking this box may then action the display of a further box ‘Show Check Character’ which provides you with the option of showing the check digit in the human readables. 

‘Show Start/Stop’: This tick box gives you the option of showing the start and stop characters in the human readables of relevant symbologies. 

‘Short Add Bars’: This option allows you to make the bars of an add-on to a barcode shorter or full length, as required. 

‘Spacer’: Ticking the spacer box option will add spacers (light margin indicators) that will act as a visual aid to help protect the light margins (quiet zones) of EAN and UPC barcodes. The spacers are displayed as greater than and/or smaller than signs (< >) outside the human readables. 

‘Description’: This box can be used to add a description to your barcode for your reference. 

‘M’: M stands for magnification factor which is applicable to many barcode symbologies and will determine the size of your code. ‘1.00’ (100%) is the nominal size of a symbol with variations either side of this to make the barcode smaller or larger.  Changes made to M will automatically affect X and Y, however Y (height) can be altered independently of M. If you go outside the bounds of a certain symbologies dimensional limits then the error ‘Not valid Magnification’ will be displayed, this can be overridden by de-selecting the ‘Establish Dimensional Limits’ check box in the ‘Preferences’ option of the ‘Options’ menu (this is not recommended unless you have checked with your customer for their approval). 

‘X’: X stands for the X-dimension. In linear and stacked symbologies the X-dimension is the nominal bar size (the width of the narrowest bar) all other bars and spaces are then calculated based upon a ratio of this size, the X dimension therefore, will have a direct impact on the size of the barcode. The X dimension is shown in FilmBars as part of a millimeter e.g. 0.33mm, (this is equivalent to 330microns) and will vary in range according to the symbology type. 

‘Y’: Y stands for Y-dimension and refers to the height of the bars in a barcode.  Y can be altered independently to determine the height of your bars, although if the symbology has a magnification factor then Y will automatically increase or decrease with the magnification. Certain application specifications have restrictions on minimum allowed bar height which should be considered when entering a figure for Y. 

‘I’: I stands for the Inter Character Gap, this is the gap in-between the characters that can only be set for certain symbologies such as Code 39 and Codabar.  By default this value will be the same as the X dimension value but it can be altered to provide a wider inter character gap if necessary, for further information see the relevant symbology standard. 

‘N’: N stands for the Wide to Narrow bar ratio, this is usually settable between 2:1 and 3:1 with the default set to 2.5:1. Altering the ratio will have a direct impact on the size of the code. 

‘BWA’: BWA stands for Bar Width Adjustment, and can be used to build in a reduction in bar size to account for any spread that will occur in printing (print gain). The BWA can have a negative, zero or positive value, but to reduce the bars in order to compensate for print gain a NEGATIVE value is required (NOTE: for users who are used to dealing with Bar Width Reduction (BWR), BWA acts as an exact opposite). The BWA is shown as ‘0.xx’ so if a reduction of the bars of 100microns is required it would be entered as ‘-0.100’. If you are planning to output your file to film before you print then you may need to compensate for any deviation in the imaging process as well as the printing process. 

‘M.S.A’.: MSA stands for Module Size Adjustment, this works in the same way as BWA (see above) but is applicable to the 2-D symbologies. 

3.2 Multiple Barcode Generation 
If you wish to generate multiple barcodes at once, this can be done using either an existing database file that you have created or by creating a sequential file using the Data Sequence Generator. 

Generating the Data 
From an Existing File (using FDB files)
It is possible to use an existing file of information to generate a batch of barcodes. The file
must however conform to a list of properties:
1) It must be a delimited file (the default is a comma, see ‘Preferences’ to change it).
2) It needs to be structured to contain the following six fields: Code Number, Description,
Text1, Text2, Text3 and Text4 per row.
3) When you save the file you will need to select the file type as a CSV file BUT change the
file extension following your file name to FDB (with some common spreadsheet packages
you may have to enclose the entire file name and extension in double quote marks in order for
it to accept FDB as a valid extension).


Using the FilmBars Editor (Windows only) This text editor can be opened either directly from the ‘FilmBars Directory’ in the ‘Windows Start Bar’ or in FilmBar Graphics via the ‘Tools’ menu.  ‘Editor’ acts as a general purpose text editor and is utilised by the FilmBar Graphics program to edit FDB files. You can also manually produce FDB files using editor but the format must conform to the list above in Using the Data Sequence File Generator If you need to produce a batch of sequential barcodes then you can generate the file containing the information that you will need using the Data Sequence File Generator which can be found under the Tools menu.  In the Data Sequence File Generator window you can use the options to input the information you want in your code including the barcode number, how much it should increment by, how many codes you need it to generate and any text and description you wish to add. You can also make individual alterations by using the Edit button. Once you are happy with your data press the Generate button, you will then be asked to save the contents of this file to the file name of your choice. 
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Generating the Symbols as a Batch (Save Batch) 
Now that you have prepared your data you need to use the Save Batch option from the File menu. First you will need to select the file that you have just saved (a FDB file generated using one of the above two methods) in the Database file box (using the ‘Edit’ button to perform any necessary editing). Then you will need to select a target file. 

Target Files and Tracking Numbers 
In order to save multiple files at a time the software requires you to generate a tracking number (which is used to generate different file names for each file), this can be done either through the ‘Tracking Number’ option of the ‘Options’ menu or by using the ‘Split’ button in the ‘Save Batch’ window.  The tracking number allows you to make up a file name of your choice but you must enter a decimal number in the ‘Counter’ box.  If you already have a file that was generated with a tracking number then you can use the Browse button in the Save Batch window and select this file, your new files will then carry on from that file counter number.  If you wish to give all of your files the same tracking number (uniquely serialised) then you can tick the Master Tracking Number tick box. 
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With the target file selected you are now ready to press the Save button, at which point the Activity Report window should show the files being generated and saved (they will automatically save to the default directory which is set in the Preferences option of the Options menu). 

3.3 Editing your Barcode 
There are several options in the software that allow you to edit certain features of your barcodes such as quiet zone size, rotation and any quality control marks. 

Quiet Zones 
Also known as Light Margins or Clear Areas.  This is the area to the left and right of a linear barcode (or all around a 2-D symbol) that is left empty in order for the symbol to be scannable. There is no option to reduce the size of these areas in the software as they are already set to the minimum and any reduction may render the symbol unreadable. You can increase the size of the quiet zones by using the ‘Quiet Zones’ option under the ‘Options’ menu, for linear codes you would generally only need to increase X (left and right hand side areas) whereas for 2-D codes you would need to increase X and Y (both left and right and top and bottom). This feature can also be used to increase the area between the light margins and the bearer bars. 

The Bearer Bars 
You have the option to surround your barcode with Bearer Bars, Frames and Corner Marks under the ‘Bearer Bars’ option of the ‘Options’ menu.  These markings have several purposes; the Bearer Bars can be used in traditional printing processes to equalize the pressure of the plate over the entire surface of the symbol, they can also be used to stop a scanner scanning diagonally across the code and short reading the barcode. The Frames and Corner Marks are used more commonly as an indication of the size of area that is be kept clear around the barcode in order to avoid scanning problems. There are seven options to choose from under the ‘Bearer Bars Properties’ window (most of which also have the option to alter the thickness by utilising the ‘Thickness’ box): 

1  None 
2  Horizontal - Bars placed across the top and bottom of the barcode from the first bar to the last. 

3  Horizontal Extended - As Horizontal but extending to include the light margin (quiet zone) areas to either side of the code. 

4  Vertical - Bars extend up the height of the bars of the barcode and are located to the left and right of the barcode outside the light margin areas. 

5  Vertical Extended - As Vertical but also including a vertical light margin (Quiet Zone Y) and any amplification of the vertical light margin. 

6  Frame - A combination of both the Horizontal Extended and the Vertical Extended Bearer Bars producing a box that encloses the symbol. The Frame does not include the Human Readable characters beneath the barcode except for those in the EAN-13, EAN-8, UPC-A, UPC-E and ITF-14 Old Style symbols. The Frame never encloses free text lines. 

7 Angle Corner Marks - These corner marks are placed to show the Bounding Box (barcode including light margins and sometimes human readables) of the barcode. 

Note: To improve scanning performance it is recommended you increase the quiet zones of the zone affected by the bearer bars by at least 1 mm (0.004”). 

Bearer Bars are optional and the default selection is ‘None’ for all the symbologies except ITF-14 and MS-7 (Marks & Spencer), the selection can be changed once the symbol is generated. The selection is permanent when it is made with no active barcode on the screen, and it is temporary when it is made with an active barcode on the screen. 

Quality Control Marks 
There are a range of quality control marks (selected from the ‘Quality Control Marks’ option of the ‘Options’ menu) that you can add to your symbols, which can then be used to provide information about the quality of your printing and filming processes. The selection is permanent when used with no active document and temporary when used with an active document. 

The selection of marks are as follows: 

DIN-Marks - These marks are generally used in conjunction with UPC-A, UPC-E, EAN-13, EAN-8 and UCC/EAN-128 symbols to assist in evaluating the quality of the printing process. For further information on DIN-Marks please see the ‘General EAN/UCC Specifications’ guide. 

H-Marks - Also known as H-Gauges, these guides are generally used in conjunction with ITF-14, ITF-6 and UCC/EAN-128 barcode symbols to assist in evaluating the quality of the printing process. For further information on H-Gauges please see the ‘General EAN/UCC Specifications’ guide. 

GRATING-41 -The GRATING-41 marks provide a quality check for the final film by creating 41 lines of equal width and spacing in 0.002mm (0.0001inches) increments from 0 to 0.080mm (0.0040inches). The idea is that the lines should provide an immediate check on how much the lines vary from intended on the final film (note: on laser printers the GRATING prints as a solid black block).  For further information see the section on ‘Calibrating Your Output Equipment’. 

Text 
It is possible to add up to four lines of free text around the barcode by choosing the Text’ option from the ‘Options’ menu.  You can then utilise the ‘Alignment’, ‘Position’, ‘Gap’ and ‘Font’ options to manipulate the location and look of each line. 

3.4 Saving and Exporting 
This section deals with the different file formats available for you to export/save to, and gives a brief explanation of the their uses. (The basic instructions on saving are provided in Chapter 2 - Software Basics and instructions on Batch Saving [multiple file generation] can be found earlier in Chapter 3 under the Multiple Barcode Generation heading). It is important to note that when placing your generated file into your required program that no resizing even proportional is carried out as this will compromise the accuracy of your barcode symbol (if a different size barcode is required then it will need to be remade and re-exported from the FilmBars package). 
FBS - FilmBars Symbol, this is a graphic format created by Symbolnology Labs that has been designed specifically with the intention of holding automatic identification symbols in a highly accurate yet economically sized format. If you are intending to reuse your file in the FilmBars software, e.g. as a template for future barcodes or to continue a sequential batch of barcodes, then you must save the file as a FBS file in order for it to be recognised by the software at a later date. 

Vector Files - Vector files are images created using sets of straight lines, and defined by the locations of the end points. Vector files such as EPS and AI files are generally of a very high quality and are the recommended format to use when saving/exporting your barcode to make your film masters. The other vector file offered under the FilmBars program is a Windows Metafile which although still of good quality is only recommended for use when printing labels directly (not for production of images to generate artwork). 

Bitmap Files (Windows only)-  A selection of Bitmap files have been offered for selection under the FilmBars package including BMP, TIF and DIB.  These options have been included because there are certain applications which only support bitmap images, however it is NOT recommended that this file format is used for production of high quality symbols. 

Adobe Type 1 Fonts 
In the Windows version of FilmBars you are provided with several fonts in Adobe Type 1 format, which are worth installing if you are intending to produce EPS or AI files.  You will need to have Adobe Type Manager installed on your PC which you can use to install the fonts using the FilmBars software disk. 

Final Note 
Your eventual choice of file format will depend on what best suits your needs for compatibility into existing programs but the most likely choice will be an EPS file for it’s accuracy levels. To make FilmBars default to save a certain type of file format, choose the ‘Preferences’ option from the ‘Options’ menu where you can enter your default file format. 

3.5 Using Tracking Numbers and Order Entry Attachments 
Tracking Numbers 
The use of Tracking Numbers has already been discussed early in this chapter under the Multiple Barcode Generation section, however there are a few further points that are worth noting. The Tracking Number dialog box can be accessed using the ‘Tracking Number’ option of the ‘Options’ menu.  You have the option to add a prefix and suffix around your counter (but the counter must be a decimal number), the total length of the tracking number must not exceed eight characters. The Master Tracking number toggle switch can be used to give all the generated FBS files a uniquely sequential serial number, thus, permitting you to follow the ISO 9000 quality standard. 
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Attaching Order Entry Information 
The Order Entry screen (which can be accessed using the ‘Order Entry’ option of the ‘Options’ menu) can be used to add order details to FBS files which can be viewed at a later date if the FBS file is re-opened in the FilmBars package (only for saved FBS files). 

3.6 Printing Labels (Windows only) 
It is possible to print directly from the FilmBars package to the printer of your choice, printing directly onto labels. You can utilise the ‘Print Setup’ option under the ‘File’ menu to select your chosen Windows printer and an appropriate paper size e.g. A4 if you have A4 sheets of labels (FilmBars requires you to have a paper size of equal to or smaller than the printer driver paper size, other wise an error will be returned). To print you need to select the ‘Print’ option from the ‘File’ menu, you will then be presented with the print labels dialog window from which you have several options. 
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Printing your Current Barcode 
If you have a barcode currently created on the screen then you can select ‘Print’ and the ‘Print Label’ dialog box will automatically fill in and disable the file ‘Source’ boxes at the top of the window leaving you the choices of label format (see below), label numbers and position of the barcode in the label. The ‘# of Labels’ option allows you to select how many labels you would like, the ‘# of Times’ option allows you to select how many times you want to repeat the set of labels and the ‘First Label’ allows you to chose at which label position you would like to start your first label. The default will be to center the barcode in the label but this can 

 be altered by toggling off the ‘Center in Label’ check box and then entering a valid figure in the ‘Right’ and ‘Down’ boxes to place your barcode as required. FilmBars will check that the barcode including light margins will fit inside the label, other wise an error message will be returned, in this case either use a smaller barcode or larger label. 

Printing from a Database of Barcodes 
If you have created a database of FDB files using the Data Sequence File Generator or by utilising a spreadsheet program (see the Multiple File Generation section earlier in this chapter for further information on these methods) then you can print directly from this FDB file (without using the Save Batch facility). This is done by closing any current barcodes you have open, ensuring the barcode symbology that you wish to use is selected then selecting the ‘Print’ option.  This time instead of the upper area of the ‘Print Labels’ dialog box being disabled it will be enabled, use the ‘Database File’ section of the form to locate and edit your file as necessary and then proceed as per above ‘Printing your Current Barcode’. The number of records (barcodes) in your file will reflect the number of labels that are printed. For example, if you created a serial file of numbers 000 to 200 with the Code 39 symbology selected at print time, then 200 sequential Code 39 barcodes should be printed, but you can choose to print less if necessary by altering the number of labels to 10 for example. 

Label Formats 
There are a number of preformatted label sizes (saved as SLF files) available for selected media types offering different label sizes and numbers of labels to a page, these formats can be edited, or alternatively you can generate your own formats. The ‘Label Formats’ window can be accessed either directly from the ‘Tools’ menu or through selecting ‘File’ ‘Print’ and then pressing the ‘Select File’ button in the ‘Print Labels’ window. In ‘Label Formats’ you choose the appropriate media manufacturer (‘Group’) and format type (‘References’). Highlighting a Group and pressing the ‘Add’ button will allow you to add new manufacturers (Groups) to the list, highlighting a Group and pressing the ‘Edit’ button will display the properties of that manufacturer (address, telephone etc). Highlighting a file in ‘References’ and pressing ‘Edit’ in that section will allow you to edit the layout of that particular label format, you can also use the ‘Add’ and ‘Remove’ buttons to create new files for that manufacturer or to delete unnecessary ones. To create your own file select the ‘User Defined’ group then press ‘Add’, the ‘Format Description’ window should then appear allowing you to set up your own format including choices for page dimensions, label dimensions and page layout. 
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The Format Description Window If you are going to edit an existing format or create a new one then the ‘Format Description’ window will be shown. This window first shows a box for the ‘Format Name’ (in which you can enter a relevant name) and an option for units (e.g. millimeters or inches), followed by a range of options as listed below: 1) Page Dimensions - here you can choose the media type i.e. continuous, sheet or fan-fold and the dimensions of the page including margins.  This information should reflect the properties of the paper that is in your printer. 2) Label Dimensions - here you enter information about the size of your individual labels on the sheet and select whether they have rounded or squared corners 3) Page Layout - here you select how the labels are to be laid out in the page including how many labels there will be across and down the page and any separation that you want to have between them, the ‘Auto Sep’ button will automatically calculate the horizontal and vertical separation for you. It is important to consider the combined widths of the label, how many labels across and any margins in the paper to avoid returning an error.  The following formulae should be considered to help calculate whether your format will work: Paper Width  = Left Margin + (Label Width * Labels Across) + (Horizontal Separation * (Labels Across - 1)) + Right margin Paper Length = Top Margin + (Label Height * Labels Down) + (Vertical Separation * (Labels Down - 1)) + Bottom Margin. 
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3.7 Copying and Pasting Symbols 
You can use the clipboard in FilmBars to copy a current barcode and then paste it into another application. This is performed by selecting ‘Copy’ from the ‘Edit’ menu, then using the paste facility in your desired program (the format of the pasted symbol will depend on the format required by the program you are pasting to). If you wish to specify the format that you will copy the file as then you can use the ‘Copy As’ function in the ‘Edit’ menu (Windows only). You will then have the choice of Windows Metafile or Windows Bitmap,  we recommend you use the Windows Metafile option as it carries a much higher level of accuracy. 

Please note: The copy/paste method is not recommended for the production of high quality artwork, where the generation and import of an EPS file is far more appropriate. 
3.8 Preferences and Views of the Program 
You can personalise some aspects of FilmBars to suit your requirements.  If you wish to zoom in on an area of the barcode you have created then this can be done using the ‘Zoom’ option of the ‘View’ menu, where you are given a range of zoom values to choose from.  The ‘View’ menu also provides you with the option of displaying the ‘Status Bar’ and ‘Toolbar’ which can be toggled to show or hide by clicking on the relevant option. 

To set up your personal preferences you can access the ‘Preferences’ option of the ‘Options’ menu. The following options are then shown: 

‘Show Welcome Screen’ check box - toggle this box on or off depending on whether you want the welcome screen to be shown upon program load. ‘Establish Dimensional Limits’ check box - FilmBars will automatically show an error

 message on the majority of occasions when you ask the software to alter a symbol in a way that violates that symbologies specification’s.  If you would like to override this warning message then you can do this by toggling off the checkbox, (the box will automatically toggle back on each time you restart the FilmBars software). ‘Order Entry’ check box - toggling this tick box on will automatically bring up the ‘Order Entry’ dialog box each time you make a new barcode or the Save Batch command is executed. 

‘Measure Units’ - Use to select either millimeters or inches. This option is disabled when an
active barcode is on the screen.
‘Directories’ (Windows only) - This is where the default path directories for saving your
generated barcodes and label formats are stored. These can be altered if you wish to default
to a different directory.
‘Defaults’ - This section of the form can be used to set various defaults:


‘Composed Code Separator Character’ and ‘FDB Separator Character’- The delimiter character is entered here for these two options. The default is comma but this can be altered if, for example, your database is tab delimited. ‘B.W.A’ - If you always use the same value for your Bar Width Adjustment then a default value can be entered here. ‘Image Setter Calibration’ - You can enter a value here to compensate for any dot gain caused by your image setter.  The image setter calibration figure will then be applied when saving or exporting using any EPS or AI format. ‘Save File As Type’ - If you always save your files as a certain format then you can set the default here. 

7) ‘Languages’ - Choose your language settings between English and Spanish. 
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Chapter 4 - External Considerations 
4.1 Calibrating your Output Equipment 
This section relates to the use of image setters for the generation of film masters. There are a variety of parameters in the imaging process that can affect the accuracy of the final film master. It is therefore important to compensate for any inaccuracy by calibrating the output equipment and entering the result into the FilmBars software, before generating your barcode. 

The frequency with which you will have to calibrate the output equipment will depend on a series of parameters and variables that might be sensitive to change during the reproduction process. Some of these parameters are as follows: 

· Image setter resolution variation (1200, 2400 and others). 

· A change in the density or filters in the exposure unit. 

· Changes in the sensitivity of the film. 

· A change in the part number of the film being used. 

· When a fall in intensity can be noticed due to depletion of the laser. 

· The state of the chemical products, etc. 

Calibrating the image-setter means finding out how much deviation is produced in the image-setter in order to compensate for it. 

4.2 Calibration Procedures 
There are several methods of calibrating your image-setter. We will describe three of the methods here, two of which are dependent on external hardware. 

Method 1 - Grating-41 
We have provided a ‘Quality Control Mark’ called ‘GRATING-41’, you should print a number of symbols (any symbology) and add to them the GRATING-41 quality control mark, with 2 gratings to be added to each symbol. Film the symbols exporting as EPS files and importing from any DTP or graphics design software, and do not scale or skew, because you will distort the finished image and results, (during this process set the Printer Calibration value to 0). 

Using a magnification glass note the number of the first pair of bars that touch for less than half their length. 

For Example: 

Metric System
Start to check from right to left, first bar on the right is labeled as 80, go left stepping by two,


e.g. checking bars 78, 76, ... If you find that bars 16 and 18 touch for more than 50% of their length and 18-20 do not touch , the value to note will be 16-18. Test the rest of samples, you may obtain different values due the nature of the film and processing, so you may have to average them. 

0-2 0 40-42 -0.040 2-4 -0.002 42-44 -0.042 4-6 -0.004 44-46 -0.044 6-8 -0.006 46-48 -0.046 8-10 -0.008 48-50 -0.048 10-12 -0.010 50-52 -0.050 12-14 -0.012 52-54 -0.052 14-16 -0.014 54-56 -0.054 16-18 -0.016 56-58 -0.056 18-20 -0.018 58-60 -0.058 20-22 -0.020 60-62 -0.060 22-24 -0.022 62-64 -0.062 24-26 -0.024 64-66 -0.064 26-28 -0.026 66-68 -0.066 28-30 -0.028 68-70 -0.068 30-32 -0.030 70-72 -0.070 32-34 -0.032 72-74 -0.072 34-36 -0.034 76-76 -0.074 36-38 -0.036 76-78 -0.076 38-40 -0.038 78-80 -0.078 

GRATING-41 Calibration Table (mm) 
Imperial System
Start to check from right to left, first bar on the right is labeled as 40, go left stepping by two,


e.g. checking bars 38, 36, ... If you find that bars 8 and 9 touch for more than 50% of their length and 9-10 do not touch, the value to note will be 8-9. Test the rest of samples, you may obtain different values due the nature of the film and processing. Average them. 

0-2 0 40-42 -0.0020 2-4 -0.0001 42-44 -0.0021 4-6 -0.0002 44-46 -0.0022 6-8 -0.0003 46-48 -0.0023 8-10 -0.0004 48-50 -0.0024 10-12 -0.0005 50-52 -0.0025 12-14 -0.0006 52-54 -0.0026 14-16 -0.0007 54-56 -0.0027 16-18 -0.0008 56-58 -0.0028 18-20 -0.0009 58-60 -0.0029 20-22 -0.0010 60-62 -0.0030 22-24 -0.0011 62-64 -0.0031 24-26 -0.0012 64-66 -0.0032 26-28 -0.0013 66-68 -0.0033 28-30 -0.0014 68-70 -0.0034 30-32 -0.0015 70-72 -0.0035 32-34 -0.0016 72-74 -0.0036 34-36 -0.0017 76-76 -0.0037 36-38 -0.0018 76-78 -0.0038 38-40 -0.0019 78-80 -0.0039 

GRATING-41 Calibration Table (inches) 
Method 2 - Film-Masters verifier 
Film a test symbol exporting as EPS files and importing into any DTP or graphics design software, and do not scale or skew, because you will distort the finished image and results. Select a symbology supported by your verifier (we suggest an EAN-13 symbol encoding 4012345678901 with a Magnification of 1.00 and B.W.A. 0). Verify several samples and average the B.W.R. difference found, if the measured BWR is  negative then the required BWA will be positive and vice versa. Use this value as the calibration value. 

Method 3 - Profile projector 
Film a test symbol exporting as an EPS file and importing into any DTP or graphics design software, and do not scale or skew, because you will distort the finished image and results. Select a symbology (we suggest an EAN-13 symbol encoding 4012345678901 with a Magnification of 1.00 and B.W.A. 0). Measure several samples and average the B.W.R. difference found, use this value as the calibration value. 

4.3 Verification 
It is highly recommended that you verify the barcode that you finally produce to ensure that it can decode properly and that no problems have occurred at any stage of it’s origination. There are many reasons why a barcode may fail to read e.g. too much ink at print time, dirty print plates, defects in printing material etc and it is generally impossible to tell by eye whether your symbol is of adequate quality. Quality control equipment (barcode verifiers) provide an accurate insight into the quality of your barcode, hopefully before you encounter any need for reprints or rejections from customers. Ideally you would verify at both the film stage and final printed stage of the barcode, however verification of film can be an expensive process and many people opt to only verify the final printed symbol. For more information on barcode verifiers contact Axicon on +44 (0)1869 351155 or visit our website at www.axicon.com. 

Chapter 5 Trouble Shooting

This chapter provides some basic trouble shooting tips, if you do not find your solution here then please contact Axicon using the details provided in the technical support section of this chapter. 

5.1 Common Problems 
� • Symbology required is not listed 

� Although the FilmBars package is capable of producing a wide range of symbologies (see ‘Chapter 7 - Technical Specifications’ for an exhaustive list) your package will be limited to the symbologies that you specified when you purchased the software. If you would like to add further symbologies then please contact Axicon for details. 

� • Error messages during symbol generation 

� Error messages are generally displayed at the symbol generation stage because one of the data fields contains invalid data. If you should be presented with an error message check that your barcode is of the correct character length for that symbology and that the magnification, truncation and BWA are of appropriate measurements.  It may be that you are requesting the software to step outside of the symbologies specification. If this is necessary then toggling off the ‘Establish Dimensional Limits’ check box in the ‘Preferences’ option of the ‘Options’ menu will remove the symbology specification boundaries (this could result in the generation of out of specification barcodes and is not recommended) . 

� • BWA value required is not listed or is returning an error. 

� Common values for BWA are listed in the pull down menu, however you can overtype the value you require into the box, remember if you want to add a reduction of 250microns then it would be added as ‘-0.250’. If an error is returned then you have probably exceeded the boundaries for that symbology, (FilmBars will automatically limit the amount of BWA you can use in relation to the symbology). 

� • Restricted/No use of certain features 

� Certain features such as ‘Rotation’, ‘Order Entry’ and saving of certain file types are specific to particular versions of FilmBars i.e. FilmBar Graphics for Windows, FilmBar Graphics for Macintosh or FilmBar FilmMasters 

� • Unable to re-open a previously saved file for editing 

� FilmBars can only re-open files which have been saved using the FBS file format, if you have saved the file as an EPS or AI file then you cannot re-open it using the FilmBars package and will have to regenerate the file. 

· Barcode is printed but is not reading properly 

If your final printed barcode is not reading properly there could be several causes. To produce an accurate barcode it is recommended that you save/export your generated barcodes as EPS or AI files, the accuracy levels of other file types is not as good and will not guarantee accurate results (the use of bitmap files in particular should be avoided). 

Use a verifier (see ‘Chapter 4 - External Considerations’) to determine the reason why your barcode is not reading properly, if there is too much bar spread then you may need to reduce the BWA further when generating the barcode to compensate for this spread.  Also check that you have left adequate space to the left and right of the barcode and that the size and truncation are in specification. If you have used printing plates then check the plates for dirt and make sure that the ink and media are compatible and that there is adequate contrast between bars and spaces. 

5.2 Technical Support 
If you require further support from the technical support team at Axicon then please contact us providing as much information about your situation as you can. If possible include the exact circumstances under which the problem occurred, the version number of the FilmBars software and the specification of the PC or Mac and operating system you are using. 

To get in touch with technical support use the following contacts; 

� * Fax.: +44 (0)1869 351616 

� * e-mail: sales@axicon.com 

Chapter 6 -Technical Specifications 
FilmBar Graphics Software 
Windows based software, version number 3.2.04 (or higher)
Or
Macintosh based software, version number 3.1.51 (or higher)


Symbologies Included: 
BASE 32 (Italian Pharma)
Bookland EAN/5
Bookland EAN/9
Bookland ISBN
Codabar
Code 11
Code 128
Code 2 of 5
Code 39 CIP (French Pharma)
Code 39 Full ASCII
Code 39 Regular
Code 39 Trioptic
Code 49
Code 93
CSPC
Custom Barcode
DataMatrix
Dot Code-A
EAN-128
EAN-13
EAN-13+
EAN-13 + EAN-128
EAN-13 Israel + EAN-128


EAN-13 Israel EAN-13 Special EAN-8 EAN-8 Special EAN-8 Woolworth’s EAN SF CCP EAN SF SCP FIM HRI IATA Baggage IATA Ticket Industrial 2/5 Interleaved 2/5 ISSN ITF-14 ITF-14 + EAN-13 ITF-14 + ITF-2 ITF-14 Israel ITF-14 Old Style ITF-6 LEB Code MaxiCode MicroPDF 14 MS-7 (Marks & Spencer) MSI Belgian Pharma MSI NDC OCR-A OCR-B ODETTE Panasonic Video PDF-417 Pharmacode (Laetus) Postnet PZN 

RM4 SCC
Spanish Pharma CCP & SCP
Sick
UCC-128
UPC-A
UPC-A Audio/Video
UPC-A+UCC-128 (Coupons)
UPC-E1
UPC-E/2B
UPC-E USD-5.
 


Features:
 Barcode image generator FBS, EPS, AI, WMF*, BMP*, DIB*  file formats supported (* = Windows only) Copy Paste facility Label formatting and printing (Windows only) Additional text lines Data Sequence File Generator Automatic check digit calculation Automatic out of specification warning Database linking with FDB Variable BWA and Image Setter compensation adjustments Variable size and height adjustments Batch conversion Rotation (Windows) Optional quality control marks, Bearer Bars, Corner Marks and Light Margin Indicators Variable light margin area Tracking number assignment including Master Tracking number (for use with ISO 9000) Order Entry screen English or Spanish language choice (Windows only) Bounding and Kernel box measurements Intelligent EAN128 Application Identifier Entry Description option 

.


System Requirements 
Windows Version
 486 or IBM PC compatible with full support to Microsoft Windows 95 or higher; 8MB RAM, 4 MB hard disk space; VGA or better color graphics, compatible mouse and ATM (Adobe Type Manager) 1.15 or higher (optional). 

Macintosh Version Macintosh Performa 68xxx and later, with system 7.0 or later. 4MB RAM (recommended 8 MB), 4 MB hard disk space. 

Chapter 7 - Disclaimer and Software License 
Software License – Filmbars Graphics


© 2000 – 2003 Axicon Auto ID Ltd – All Rights Reserved.
“Filmbars”, “Filmbars Graphics” and all products made or distributed by Symbolology Labs are
registered trademarks of Axicon Auto ID Ltd.  All other products or trademarks mentioned are the
property of their respective owners.


Axicon Auto ID Ltd has prepared this manual and software to be used by its personnel, licensees
and customers. The information contained in them is the property of Axicon Auto ID Ltd and may
not be reproduced under any circumstances either in a partial or a complete form without prior
written consent.


The information contained in the manual and in the software may not be stored in any other form
other than that in which it has been supplied by Axicon Auto ID Ltd, save for the purpose of
required computer data backups by its licensees and customers. Expressly, any attempt to disassemble the software is in direct breach of the terms of the license.


Axicon Auto ID Ltd reserves the right to make any changes deemed necessary in the specifications
and/or material without prior notice and takes no responsibility for possible damages, including
those which may come as a result of, or be caused by the aforementioned material including, but not
limited to, typographical, mathematical or listing errors.
No responsibility will be assumed for infringement of patents, copyrights or any third party rights
due to the use they may be given.


Axicon Auto ID does not guarantee that the Filmbars Graphics program will run correctly in all
hardware and software environments. Axicon Auto ID provides facilities for a “demonstration
version” of the software to be available to potential licensees so that a licensee may evaluate the
suitability of the product for their purposes prior to purchase. Filmbars Graphics may not work with
modified operating systems, with certain software applications residing in memory, or hardware that
is not 100% compatible.


The Filmbars Graphics license offered is for the current release of software available at the time the
order is received by Axicon Auto ID.
Axicon Auto ID does not offer any guarantee that the Filmbars Graphics program will run correctly
under any future computer operating system, or hardware, nor does Axicon Auto ID guarantee that it
will make a new release of the software available to work under any future computer operating
system.


Changes to the computer operating system, the computer hardware or the introduction of other
software to the system resulting in incompatibilities are the responsibility of the licensee. All
Filmbars Graphics updates/upgrades are chargeable.


The Filmbars Graphics license offered is a single user license for personal use ONLY. A “softkey”
or a dongle (hardkey) is used to activate the software for a single computer system. This installation
is not-transferable to any other computer and the license is not transferable to any other owner.


The license is for personal use ONLY – to generate barcode images for use by the licensee exclusively. Should the licensee wish to generate barcode images for sale to a third-party then it will be
necessary for the licensee to purchase a license for the “Filmbars Graphics for Film Masters”
product.


Although Axicon Auto ID has tested the software supplied, AXICON AUTO ID DOES NOT
GUARANTEE, EITHER EXPLICITLY OR IMPLICITLY, THE QUALITY, APPLICATION, OR
UTILISATION OF THIS PRODUCT AND ITS DOCUMENTATION FOR A DETERMINED
PURPOSE. CONSEQUENTLY, THIS PRODUCT AND DOCUMENTATION ARE LICENSED
“AS IS”, AND IT IS THE LICENSEE WHO MUST ASSUME THE RISK INSOFAR AS THE
QUALITY AND APPLICATION. THE LICENSEE, AND NOT AXICON AUTO ID, WILL
ASSUME ALL NECESSARY REPAIR COSTS. AXICON AUTO ID RESERVES THE RIGHT TO
REVISE THIS MANUAL, ITS ACCOMPANYING SOFTWARE AND DOCUMENTATION
MAKING ANY CHANGES DEEMED NECESSARY IN THEIR CONTENT WITH NO OBLIGA
TION TO NOTIFY ANY PERSON OR ORGANISATION ABOUT SAID REVISION OR MODI
FICATION.
UNDER NO CIRCUMSTANCES WILL AXICON AUTO ID ASSUME RESPONSIBILITY FOR
ANY DAMAGE INCURRED, EITHER DIRECTLY, INDIRECTLY, SPECIAL, INCIDENTAL OR
CONSEQUENTIAL AS A RESULT OF USE OR THE IMPOSSIBILITY TO MAKE USE OF
THIS PRODUCT AND/OR DOCUMENTATION, even when forewarned about the possibility of
causing said damage.
Axicon Auto ID does not assume responsibility for any hardware, software or data stored or used
with this product, including reparation costs and replacement of hardware, software or data.


© 2000 – 2010 Axicon Auto ID Ltd – All Rights Reserved.
“Filmbars”, “Filmbars Graphics” and all products made or distributed by Symbollogy Labs are
registered trademarks of Axicon Auto ID Ltd.
All other products or trademarks mentioned are the property of their respective owners.
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